A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Exercícios 1.Elabore um algoritmo que solicite ao usuário um número e apresente os resultados da tabuada de multiplicar deste número, a qual deverá ser.

Apresentações semelhantes


Apresentação em tema: "Exercícios 1.Elabore um algoritmo que solicite ao usuário um número e apresente os resultados da tabuada de multiplicar deste número, a qual deverá ser."— Transcrição da apresentação:

1 Exercícios 1.Elabore um algoritmo que solicite ao usuário um número e apresente os resultados da tabuada de multiplicar deste número, a qual deverá ser impressa no seguinte formato (considerando o fornecimento do número 2): 2 x 1 = 2 2 x 2 = 4 2 x 3 = 6 2 x 4 = 8 2 x 5 = 10 2 x 6 = 12 2 x 7 = 14 2 x 8 = 16 2 x 9 = 18 2 x 10 = 20

2 Exercícios 2.Apresentar o total da soma obtida dos cem primeiros números inteiros ( ). 3.Elaborar um programa que apresente no final o somatório dos valores inteiros pares existentes na faixa de 1 até Elaborar um programa que apresente os valores de conversão de graus Celsius em Fahrenheit, de 10 em 10 graus, iniciando a contagem em 10 graus Celsius e finalizando em 100 graus Celsius. O programa deve apresentar os valores das duas temperaturas. A fórmula de conversão F <- (9 * C + 160) / 5 5.Elaborar um programa que efetue a leitura de valores positivos inteiros até que um valor negativo seja informado. Ao final devem ser apresentados o maior e o menor valores informados pelo usuário.

3 Resposta – 1º programa TABUADA var CONT,NUMERO:inteiro inicio escreva "Digite um número: " leia NUMERO CONT <- 1 enquanto (CONT <= 10) faca escreva NUMERO," X",CONT," =",NUMERO*CONT CONT <- CONT + 1 fim_enquanto fim

4 Resposta – 2º programa ACUMULADOR var CONTADOR,ACUMULADOR:inteiro inicio CONTADOR <-1 ACUMULADOR <-0 enquanto (CONTADOR<=100) faça ACUMULADOR <- ACUMULADOR + CONTADOR CONTADOR <- CONTADOR + 1 fim_enquanto escreva ACUMULADOR fim

5 Resposta – 3º programa SOMA_PARES_DE_1_A_50 var CONTADOR,ACUMULADOR:inteiro inicio CONTADOR <- 1 ACUMULADOR <- 0 enquanto (CONTADOR <= 50) faça se (CONTADOR mod 2 = 0) então ACUMULADOR <- ACUMULADOR + CONTADOR fim_se CONTADOR <- CONTADOR + 1 fim_enquanto escreva ACUMULADOR fim

6 Resposta – 4º programa TABELA_CELCIUS_FAHRENHEIT_10_A_10 var C,F:real inicio C <- 10 enquanto (C <= 100) faça F <- (9 * C + 160) / 5 escreva C,"ºC"," são",F,"ºF" C <- C + 10 fim_enquanto fim

7 Resposta – 5º programa MAIOR_MENOR var NUMERO,MAIOR,MENOR:inteiro inicio leia (NUMERO) MAIOR <- NUMERO MENOR <- NUMERO enquanto (NUMERO >= 0) faça se (NUMERO > MAIOR) então MAIOR <- NUMERO fim_se se (NUMERO < MENOR) então MENOR <- NUMERO fim_se leia NUMERO fim_enquanto escreva "Maior: ",MAIOR escreva "Menor: ",MENOR fim

8 Laço de Repetição com Teste Lógico no Fim do Looping programa "Pede_Numero" var X: inteiro R: inteiro inicio leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R fim

9 Laço de Repetição com Teste Lógico no Fim do Looping repita instruções executadas até que a condição se torne verdadeira até_que (Condição)

10 Laço de Repetição com Teste Lógico no Fim do Looping programa LOOPING_2A var X, R, CONT: inteiro início CONT <- 1 repita leia X R <- X * 3 escreva R CONT <- CONT + 1 até_que (CONT > 5) fim

11 Exemplo 1.Iniciar o programa e o modo de laço repita; 2.Ler um valor para a variável X ; 3.Efetuar a multiplicação do valor de X por 3, implicando o resultado em R; 4.Apresentar o valor calculado contido na variável R; 5.Solicitar do usuário se este deseja ou não continuar o programa; 6.Repetir os passos 2, 3, 4 e 5 até que a resposta do usuário seja diferente de sim.

12 Exemplo programa LOOPING_2B var X, R: inteiro RESP: caracter início RESP <- "sim" repita leia X R <- X * 3 escreva R escreva "Deseja continuar? " leia RESP até_que (RESP <> "sim") fim

13 Laço de Repetição com Variável de Controle Conceito: Laço de repetição usado quando se sabe exatamente quantas repetições serão necessária para a execução de um programa. Português Estruturado para de até passo faça fim_para

14 Laço de Repetição com Variável de Controle Diagrama de Blocos

15 Laço de Repetição com Variável de Controle programa "Pede_Numero" var X: inteiro R: inteiro inicio leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R leia X R <- X * 3 escreva R fim

16 Laço de Repetição com Variável de Controle Programa LOOPING_PARA var R, X, CONT : inteiro início para CONT de 1 até 5 passo 1 faça leia X R X * 3 escreva R fim_para fim

17 Laço de Repetição com Variável de Controle Exemplo de algoritmo que não pode ser resolvido usando o laço de repetição com variável de controle: Faça um algoritmo que leia vários números e que informe quantos desses números entre 100 e 200 foram digitados. Quando o valor 0 (zero) for lido o algoritmo deverá cessar sua execução.


Carregar ppt "Exercícios 1.Elabore um algoritmo que solicite ao usuário um número e apresente os resultados da tabuada de multiplicar deste número, a qual deverá ser."

Apresentações semelhantes


Anúncios Google