A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Soluções Laboratório III. P1 P2 algoritmo converte //Escreva um programa que permite ao usuário converter entre escalas de temperatura (Celsius, Kelvin.

Apresentações semelhantes


Apresentação em tema: "Soluções Laboratório III. P1 P2 algoritmo converte //Escreva um programa que permite ao usuário converter entre escalas de temperatura (Celsius, Kelvin."— Transcrição da apresentação:

1 Soluções Laboratório III

2 P1

3

4 P2 algoritmo converte //Escreva um programa que permite ao usuário converter entre escalas de temperatura (Celsius, Kelvin e Fahrenheit). var op:caractere cels, Fa,Ke: real inicio escreval("Entre com a temperatura em Celsius") leia (cels) escreval("Escolha k para converter para grau kelvin") escreval("Escolha F para converter para grau Fahrenheit") leia(op) se (op = "F") entao Fa <- 18/10*cels + 32 escreval("A temperatura em graus Fahrenheit e") escreval(Fa) senao se (op ="k") entao Ke <- (cels+273) escreval("A temperatura em graus Kelvin e", ke) senao escreval("nenhuma opcao selecionada") fimse fimalgoritmo

5 P3

6 P4 Algoritmo Menu_de_Opcoes Var A, B: real; opcao:inteiro; inicio escreva("Entre com dois numeros); leia(A); leia(B); escreva("Digite 1 para soma); escreva("Digite 2 para subtraçao); escreva("Digite 3 para Divisao); escreva("Digite 4 para Raiz); leia(opcao); escolha opcao caso 1: C <- A+B; escreva("O resultado da soma é", C); caso 2: C <- A-B; escreva("O resultado da subtração é", C); caso 3: C <- A/B; escreva("O resultado da divisao é", C); caso 4: se A>=0 faca C <- Raiz(A,2); escreva("O resultado da raiz é", C); senão escreva("Impossivel Imprimir"); outro: escreva("Fim do Caso"); fim_caso; fim --- fim_algoritmo

7 P5

8

9 P6

10 P7 Solução?


Carregar ppt "Soluções Laboratório III. P1 P2 algoritmo converte //Escreva um programa que permite ao usuário converter entre escalas de temperatura (Celsius, Kelvin."

Apresentações semelhantes


Anúncios Google