A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL Estruturas de Repetição Estruturas de Repetição - Enquanto / Fim Enquanto Enquanto.

Apresentações semelhantes


Apresentação em tema: "CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL Estruturas de Repetição Estruturas de Repetição - Enquanto / Fim Enquanto Enquanto."— Transcrição da apresentação:

1 CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL Estruturas de Repetição Estruturas de Repetição - Enquanto / Fim Enquanto Enquanto condição faça - - comandos - Fim Enquanto Neste caso, o bloco de operações será executado enquanto a condição for verdadeira. O teste de condição será sempre realizado antes de qualquer operação. Enquanto a condição for verdadeira o processo se repete. Podemos utilizar essa estrutura para trabalharmos com contadores.

2 Exemplo 1: Mostrar os números pares de 2 a 10 Programa Laço1 Var p: inteiro Início P <- 2 Mostre (Sequencia par de 2 a 10) Enquanto p<= 10 faça mostre (p) p <- p + 2 Fim enquanto mostre (Acabou...) Fim

3 Exemplo 2: Mostrar sequência de nº positivos de 1 até N (nº recebido) Programa Laço2 Var cont: inteiro n: real Início n <- 0 cont <- 0 mostre (Sequencia de 0 até N) mostre (Informe número positivo) leia (n) Enquanto n <= 0 faça mostre (Você informou nº negativo, digite um nº maior que 0:) leia(n) Fim enquanto Enquanto cont <= n faça mostre (cont) cont <- cont + 1 Fim enquanto mostre (Até mais,... Acabou...) Fim

4 Exercícios 1 – Fazer os algoritmos para mostrar as seqüências numéricas a seguir: a)0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15 b)15,14,13,12,11,10,9,8,7,6,5,4,3,2,1,0 c)0,1,2,3,4,5,6,7,8,9,10,11,...,N d)0,2,4,6,8,10,12,14,16,18,20,...,N e)1,3,5,7,9,11,13,15,17,19,21,...,N f)5,10,15,20,25,30,35,40,45,50,55,...,N


Carregar ppt "CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL Estruturas de Repetição Estruturas de Repetição - Enquanto / Fim Enquanto Enquanto."

Apresentações semelhantes


Anúncios Google