A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Microsoft Office Excel 2010. Referências  As fórmulas e funções utilizam referências a células ou a um conjunto de células. Exemplo: B1  Existem 3 tipos.

Apresentações semelhantes


Apresentação em tema: "Microsoft Office Excel 2010. Referências  As fórmulas e funções utilizam referências a células ou a um conjunto de células. Exemplo: B1  Existem 3 tipos."— Transcrição da apresentação:

1 Microsoft Office Excel 2010

2 Referências  As fórmulas e funções utilizam referências a células ou a um conjunto de células. Exemplo: B1  Existem 3 tipos de referências: Relativas; Absolutas; Mistas.

3 Referências relativas Quando se copia uma fórmula, as referências a linhas e colunas alteram-se, isto é, a fórmula adapta-se à célula de destino, de acordo com a “distância” entre a célula de origem e a célula de destino. Isto acontece por defeito.  Se agora se copiar a célula A2 para B3, como a célula de destino se encontra uma coluna à direita e uma linha abaixo, a fórmula altera-se automaticamente para =B2+20.  O único elemento da fórmula que varia é a referência à célula A1: ao copiá-la uma coluna para a direita e uma linha para baixo, o nome da coluna incrementa uma unidade e o número da linha também, ou seja, em vez de A passa a ser B e o número da linha passa a ser 2 (a célula de destino dista uma coluna e uma linha da de origem). EXEMPLO: Referências

4 Referências absolutas Neste caso, as referências a linhas e a colunas não se alteram. Ao copiar-se uma fórmula para outra célula, as referências permanecem fixas.  Se agora se copiar a célula A2 para B3, embora a célula de destino se encontre uma coluna à direita e uma linha abaixo, como se utilizou o símbolo $ antes do identificador de coluna e antes do identificador de linha, a fórmula permanece igual; assim, em B3, teremos =$A1+20. EXEMPLO: Referências

5 Referências mistas Neste caso pode fazer-se uma combinação de ambas as referências, isto é, pode utilizar-se uma referência relativa para a coluna e uma referência fixa para a linha, e vice-versa.  Se neste caso se copiar a célula A2 para a célula B3, como existe um símbolo $ antes do indicador de coluna, esta permanece fixa; contudo a linha mudará de 1 para 2 e o resultado será =$A2+20. EXEMPLO: Referências

6  As referência mistas, como vimos, são uma combinação das outras duas e, assim sendo, deve preceder-se a coluna ou a linha do símbolo $, dependendo do que se pretende fixar ($A12, B$23, AA$1,…).  Pode-se alterar automaticamente o tipo de referência pressionando a tecla F4 enquanto se edita a fórmula e no momento em que se indicam as células referenciadas.  Referência relativa – não apresenta qualquer cifrão, por isso não tem elementos fixos. Ou seja, quando copiada, adapta-se à nova localização.  Referência absoluta – apresenta um cifrão antes da coluna e um cifrão antes da linha, ou seja, ambos os elementos são fixos. Quando copiada, não sofre qualquer alteração.  Referência mista – apresenta um cifrão antes da linha ou da coluna, isto é, a linha ou a coluna é fixa. Ao ser copiada, o elemento fixo não sofre alterações, enquanto que o elemento não fixo se adapta à nova posição. Referências

7 Fórmulas Para visualizar o conteúdo de uma fórmula, clica-se na célula respectiva para a activar e observa-se a barra de fórmulas ou passa-se a célula para o modo de edição (duplo clique).

8 Fórmulas  Nas fórmulas podemos combinar diferentes tipos de dados. Uma fórmula inicia-se sempre com o sinal igual (=).

9 Fórmulas Elementos constituintes de uma fórmula  Constantes;  Referências;  Funções;  Nomes de intervalos;  Operadores.  Exemplo: = Soma(A1:A4)*B

10 Fórmulas O Excel dispõe de quatro tipos de operadores de cálculo distintos:  Operadores aritméticos;  Operadores relacionais;  Operadores de texto;  Operadores de referência.

11 Joana Sousa Fórmulas  Operadores aritméticos

12 Fórmulas  Operadores de comparação

13 Fórmulas  Operadores de texto Exemplo 1 – Unir ou concatenar as duas cadeias de texto para produzir uma única: “Olá tudo bem”. =”Olá tudo “&”bem” Exemplo 2 – Ligar ou concatenar quatro cadeias de caracteres, separadas pelo carácter espaço (“ “), para produzir um valor de texto contínuo. =A1&” “&B1&” “&C1&” “&D1

14 Fórmulas  Operadores de referência

15 Funções  Uma função é uma fórmula predefinida, que permite executar cálculos complexos de forma simplificada, retornando um valor.  Função simples Exemplos:  =B1+B2+B3+B4+B5+B6+B7+B8  =B2-B1  =B1/B2  =(B1*B2)/2

16 Funções  Funções complexas Exemplos:  =SOMA(B1:C8)  =MEDIA(B1:C8)  =MAXIMO(B1:C8)  =MINIMO(B1:C8)  =PRODUTO(B1:C8)  =CONTAR(B1:C8)

17 Funções  Existem muitos tipos de funções, sendo que se encontram agrupadas de acordo com o tipo de operação ou cálculo que realizam.  Funções matemáticas e trigonométricas, Estatísticas, financeiras, de texto, de datas e horas, lógicas, de base de dados, de procura e referência e de informação. Exemplos de funções matemáticas ABS(número) Devolve o valor absoluto de um número Exemplo: =ABS(-45) devolve 45 ALEATORIO() Devolve um número entre 0 e 1 Exemplo: =ALEATORIO() devolve 0,


Carregar ppt "Microsoft Office Excel 2010. Referências  As fórmulas e funções utilizam referências a células ou a um conjunto de células. Exemplo: B1  Existem 3 tipos."

Apresentações semelhantes


Anúncios Google