A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

CÁLCULO DA INVERSA DA BASE Prof. M.Sc. FÁBIO FRANCISCO DA COSTA FONTES Setembro - 2009.

Apresentações semelhantes


Apresentação em tema: "CÁLCULO DA INVERSA DA BASE Prof. M.Sc. FÁBIO FRANCISCO DA COSTA FONTES Setembro - 2009."— Transcrição da apresentação:

1 CÁLCULO DA INVERSA DA BASE Prof. M.Sc. FÁBIO FRANCISCO DA COSTA FONTES Setembro

2 O método simplex revisado não computa a inversa B -1 da base diretamente. A primeira base considerada é sempre uma matriz identidade: B = I B -1 = I A partir dessa base, as demais são calculadas por um procedimento computacional, que será mostrado a seguir. Cálculo da inversa da base

3 Seja uma matriz identidade representada por: I m = (e 1, e 2,..., e m ) Onde e i são vetores identidade, com o elemento 1 na linha i. Sejam x K a variável que entra na base, a ik o coeficiente de x K na iteração i e r o número da equação que contém a variável que sai. A próxima inversa da base pode ser calculada, a partir da inversa atual, fazendo-se a seguinte operação.

4 Cálculo da inversa da base B -1 nova = E. B -1 Onde a matriz E é dada por E = (e 1, e 2,..., e r-1, δ, e r+1,..., e m ) e o vetor δ é formado da seguinte forma:

5 Cálculo da inversa da base - a ik / a rk : δ = 1/ a rk : - a ik / a rk Onde usamos: - a ik / a rk ; se ir 1/ a rk ; se i = r a rk pivô

6 Cálculo da inversa da base Assim, a matriz E é uma matriz identidade onde a coluna r foi substituída pelo vetor calculado acima. Através deste procedimento, as inversas das bases serão calculadas sucessivamente de uma Forma computacionalmente simples.

7 SIMPLEX Exemplo para explicação do algoritmo do método simplex revisado Max x 1 + x 2 s.a: 2x 1 + x 2 2 s.a: 2x 1 +x 2 + x 3 =2 x 1 + 3x 2 3 x 1 +3x 2 +x 4 =3 x 1 0 e x 2 0 x 1,x 2,x 3,x 4 0

8 simplex x1 x2 x3 x4 b x ½ 0 0 x E= -½ ½ 0 1 x1 1 ½ ½ /5 0 x4 0 5/2 -½ /5 0 0 ½ -½ /5 1

9 simplex x /5 -1/5 3/5 x /5 2/5 4/ /5 -1/5 -7/5

10 Algoritmo Simplex Revisado Inicialização: Determine uma partição para a matriz A dada por A=[B : N] e em conseqüência para c T =[c B T : C N T ] e x T =[x B T :x N T ] logica verdade Enquanto (logica) faça //teste de otimalidade// Se (c N -c B T B -1 N i ) < = 0 Lógica falso Senão b j B -1 b N j i B -1 N j i Se N j i < = 0 j=1,...,m Escreva(Saida p/ ilimitação) halt Senão Min{b j /N j i tal que N j i > 0)} E (e 1, e 2,...,e r-1, δ, e r+1,..., e m ) B -1 E.B -1 Fim se Fim enquanto Z c B T B -1 b x B E.x B escreva (Z, x B ) Fim


Carregar ppt "CÁLCULO DA INVERSA DA BASE Prof. M.Sc. FÁBIO FRANCISCO DA COSTA FONTES Setembro - 2009."

Apresentações semelhantes


Anúncios Google