A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Universidade Federal do Espírito Santo Programação II Estrutura de Repetição Professora: Norminda Luiza.

Apresentações semelhantes


Apresentação em tema: "Universidade Federal do Espírito Santo Programação II Estrutura de Repetição Professora: Norminda Luiza."— Transcrição da apresentação:

1 Universidade Federal do Espírito Santo Programação II Estrutura de Repetição Professora: Norminda Luiza

2 Estrutura de Repetição A estrutura condicional permite que trechos do algoritmo sejam repetidos e, a esses trechos damos o nome de laços de repetição. O número de repetições pode ser indeterminado, porém FINITO. Repetição com teste no início Considere em uma estrutura de controle do fluxo de execução que permite repetir diversas vezes um mesmo trecho do algoritmo, porém, sempre vefiricando antes de cada execução se é permitido executar o mesmo trecho. Sintaxe (Algoritmo): enquanto faça bloco de comandos fimenquanto Sintaxe (Linguagem C): while (condição) { bloco de comandos } Quando o resultado de for falso, o comando de repetição é abandonado e o algoritmo continua imediatamente após o final da estrutura. Se ocorrer no primeiro teste, condição igual a falso, o bloco de comandos não será executado nenhuma vez. Ver teste_while1.c

3 Estrutura de Repetição Repetição com teste no final A estrutura repita permite que um bloco de comandos seja repetido até que uma determinada condição seja verdadeira. Pela sintaxe da estrutura o bloco de comandos é executado pelo menos uma vez. Sintaxe (Algoritmo): repita bloco de comandos enquanto Sintaxe (Linguagem C): do { bloco de comandos } while (condição) Exemplo (Linguagem C): do { printf(Digite um número positivo: ); scanf(%d,&num); if (num <= 0) printf(Número negativo); while (num < 0) Exemplo (Algoritmo): repita escreva(Digite um número positivo: ) leia(num); se (num <= 0) então escreva(Número negativo) fimse enquanto (num < 0) Ver teste_barrat.c

4 Estrutura de Repetição Repetição com variável de controle A estrutura para executa um bloco de comandos uma quantidade determinada de vezes e possui limites fixos. Sintaxe (Algoritmo): para v de vi até vf passo p faça bloco de comandos fimpara Sintaxe (Linguagem C): For (inicialização; condição; incremento){ bloco de comandos } Em sua forma mais simples, a inicialização é um comando de atribuição que o compilador usa para estabelecer a variável de controle do laço. A condição é uma expressão de relação que testa a variável de controle do laço contra algum valor para determinar quando terminará as repetições. O incremento define a maneira como a variável de controle do laço será alterada cada vez que o computador repetir o laço. int count; for ( count = 1; count <= 100; count++) printf ("%d ", count); int x, y; for (x=0, y=0; x+y<100; x++,y++) printf("%d ",x+y); Exemplos: Ver teste_for.c


Carregar ppt "Universidade Federal do Espírito Santo Programação II Estrutura de Repetição Professora: Norminda Luiza."

Apresentações semelhantes


Anúncios Google