A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Algoritmos Comandos condicionais. 2 Problema: Se cair a bola vermelha o retângulo deve ficar deitado, mas se cair a bola amarela, ele deve ficar em pé.

Apresentações semelhantes


Apresentação em tema: "Algoritmos Comandos condicionais. 2 Problema: Se cair a bola vermelha o retângulo deve ficar deitado, mas se cair a bola amarela, ele deve ficar em pé."— Transcrição da apresentação:

1 Algoritmos Comandos condicionais

2 2 Problema: Se cair a bola vermelha o retângulo deve ficar deitado, mas se cair a bola amarela, ele deve ficar em pé. Alguém sabe qual vai ser a resposta que o computador vai apresentar?

3 3 Comandos condicionais Se condição vf

4 4 Comandos condicionais algoritmo bolas { determina, a partir da cor da bola qual a posição do retânguilo} declare cor: literal posicao: inteiro início { leitura da cor da bola } leia(cor) { verificação } se cor = vermelha então posicao 0 senão posicao 1 fim-se { saída } desenhe_retangulo(posicao) fim

5 5 Comandos condicionais Problema: O aluno vai fazer 2 provas e precisa obter média acima ou igual a 6,0 para ser aprovado. Alguém sabe qual a mensagem que o computador vai fornecer antes do professor informar ao computador a nota do aluno?

6 6 Comandos condicionais algoritmo aprovação { determina, a partir de duas notas, a média e se houve aprovação } declare notaProva1, notaProva2, média: real mensagem: literal início { leitura } leia(notaProva1, notaProva2) { cálculo } média (notaProva1 + notaProva2) / 2 { verificação } se média 6.0 então mensagem Aprovado senão mensagem Reprovado fim-se { saída } escreva(média, mensagem) fim

7 7 Comandos condicionais se expressão-lógica então lista-de-comandos-se-verdadeiro fim-se se expressão-lógica então lista-de-comandos-se-verdadeiro senão lista-de-comandos-se-falso fim-se Se a expressão-lógica resultar em verdadeiro, a lista-de-comandos-se- verdadeiro é executada; se resultar em falso, não. Se houver a especificação do senão e a expressão- lógica resultar em falso, a lista-de-comandos-se-falso é executada.

8 8 Comandos condicionais Aninhamento de comandosAninhamento de comandos –Os comandos internos de um comando condicional podem ser Leituras Escritas Outros comandos condicionais Ou seja, qualquer comando se expressão-lógica-1 então comando_1 comando_2 se expressão-lógica-2 então comando_3 fim-se senão se expressão-lógica-3 então se expressão-lógica-4 então comando_4 fim-se senão comando_5 fim-se

9 9 Comandos condicionais caso condição-inteira lista-de-seleção fim-caso lista-de-coincidência: lista-de-comandos lista de constantes ou intervalos caso condição-inteira lista-de-seleção senão lista-de-comandos-de-exceção fim-caso

10 10 Comandos condicionais... leia(idade) caso idade 0: escreva(nenê) 1..9: escreva(criança) 10-13: escreva(pré-adolecente) 15: escreva(debutante) 14, 16-18: escreva(adolecente) 19-99: escreva(adulto) senão escreva(idade não classificada) fim-caso...


Carregar ppt "Algoritmos Comandos condicionais. 2 Problema: Se cair a bola vermelha o retângulo deve ficar deitado, mas se cair a bola amarela, ele deve ficar em pé."

Apresentações semelhantes


Anúncios Google