A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Algoritmos e Programação Thyago Maia Tavares de Farias Aula 6.

Apresentações semelhantes


Apresentação em tema: "Algoritmos e Programação Thyago Maia Tavares de Farias Aula 6."— Transcrição da apresentação:

1 Algoritmos e Programação Thyago Maia Tavares de Farias Aula 6

2 Sumário Estrutura condicional (continuação); Estrutura condicional (continuação); Estrutura condicional (continuação); Estrutura condicional (continuação); Comando de seleção múltipla (Escolha...caso); Comando de seleção múltipla (Escolha...caso); Comando de seleção múltipla (Escolha...caso); Comando de seleção múltipla (Escolha...caso);

3 Exemplo Algoritmo: Controle de entrada em boate. Tal algoritmo avisa se uma pessoa pode entrar ou não, e quanto deverá pagar para entrar. Algoritmo: Controle de entrada em boate. Tal algoritmo avisa se uma pessoa pode entrar ou não, e quanto deverá pagar para entrar. Homens e mulheres abaixo de 18 anos não podem entrar. Homens pagam R$ 20,00. Mulheres pagam R$ 10,00 Homens e mulheres abaixo de 18 anos não podem entrar. Homens pagam R$ 20,00. Mulheres pagam R$ 10,00

4 Exemplo algoritmo entrada_boate varsexo: literal idade: inteiro inicio escreval(Digite sexo e idade) leia(sexo)leia(idade) se (idade < 18) entao escreval(Entrada proibida) senao se (sexo=M) escreva(Entrada liberada: R$ 20,00) escreva(Entrada liberada: R$ 20,00)fimse se (sexo=F) escreva(Entrada liberada: R$ 10,00) escreva(Entrada liberada: R$ 10,00)fimse fimalgoritmo fimalgoritmo

5 Exercício Elaborar um algoritmo que efetue o cálculo do reajuste de salário de um funcionário. Considere que o funcionário deverá receber um reajuste de 15% (0.15) se seu salário seja menor ou igual a 500. Caso contrario, seu reajuste será de 10% (0.1). Elaborar um algoritmo que efetue o cálculo do reajuste de salário de um funcionário. Considere que o funcionário deverá receber um reajuste de 15% (0.15) se seu salário seja menor ou igual a 500. Caso contrario, seu reajuste será de 10% (0.1).

6 Comando de seleção múltipla Em algumas situações é necessário termos várias soluções ligadas a repostas diferentes; Em algumas situações é necessário termos várias soluções ligadas a repostas diferentes; O comando se nos permite implementar tais situações, porém de forma limitada e, em alguns casos, ineficiente: O comando se nos permite implementar tais situações, porém de forma limitada e, em alguns casos, ineficiente: Imagine implementar 100 estruturas do tipo se para 100 condições diferentes! Imagine implementar 100 estruturas do tipo se para 100 condições diferentes! Tal comando obriga o programador a escrever várias linhas de código; Tal comando obriga o programador a escrever várias linhas de código;

7 Comando de seleção múltipla Para várias condições, podemos utilizar o comando de seleção múltipla escolha; Para várias condições, podemos utilizar o comando de seleção múltipla escolha; escolha expressao caso resultado_1 // Lista de instruções caso resultado_2 // Lista de instruções...outrocaso fimescolha

8 Comando de seleção múltipla As palavras reservadas escolha e fimescolha delimitam a região que fará a seleção múltipla; As palavras reservadas escolha e fimescolha delimitam a região que fará a seleção múltipla; O comando escolha seleciona uma expressão ou variável para ser comparada com os valores especificados nos comandos caso; O comando escolha seleciona uma expressão ou variável para ser comparada com os valores especificados nos comandos caso; O comando caso tem o funcionamento similar ao comando se, visto anteriormente; O comando caso tem o funcionamento similar ao comando se, visto anteriormente; O comando outrocaso tem o funcionamento similar ao comando senao, visto anteriormente; O comando outrocaso tem o funcionamento similar ao comando senao, visto anteriormente;

9 Comando de seleção múltipla Exemplo: Exemplo: algoritmo exemplo_caso var sexo: literal inicio escreval(Digite seu sexo (M ou F)) leia(sexo)escolha(sexo) caso M escreval(O usuário é Homem) caso F escreval(O usuário é Mulher) fimescolhafimalgoritmo

10 Comando de seleção múltipla Exemplo 2: Exemplo 2: algoritmo menor_idade var idade: inteiro inicio escreval(Digite sua idade:) leia(idade)escolha(idade) caso 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17 escreval(Menor de idade) outrocaso escreval(Maior de idade) fimescolhafimalgoritmo

11 Exercícios Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o número 1. Caso o número não corresponder a um dia da semana, é exibida uma mensagem de erro; Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o número 1. Caso o número não corresponder a um dia da semana, é exibida uma mensagem de erro; Faça um algoritmo que lê uma letra e informa se a mesma é uma vogal ou consoante. A mesma deverá exibir uma mensagem de erro no caso de digitação incorreta; Faça um algoritmo que lê uma letra e informa se a mesma é uma vogal ou consoante. A mesma deverá exibir uma mensagem de erro no caso de digitação incorreta;

12 Exercícios Faça um algoritmo (utilizando o comando escolha) que, baseado no código digitado pelo usuário, retorne o nome e valor do produto. Faça um algoritmo (utilizando o comando escolha) que, baseado no código digitado pelo usuário, retorne o nome e valor do produto. Sabendo que Sabendo que 001 – Parafuso (R$ 0,15) 001 – Parafuso (R$ 0,15) 002 – Porca (R$ 0,05) 002 – Porca (R$ 0,05) 003 – Prego (R$ 0,10) 003 – Prego (R$ 0,10) 004 – Martelo (R$ 40,00) 004 – Martelo (R$ 40,00) 005 – Tomada (R$ 3,00) 005 – Tomada (R$ 3,00)

13 Exercícios Faça um algoritmo que receba dois números, um operador matemático (+,-,*,/) e efetue o cálculo matemático baseado no operador digitado. O resultado deverá ser exibido em seguida. Utilize o comando escolha. Faça um algoritmo que receba dois números, um operador matemático (+,-,*,/) e efetue o cálculo matemático baseado no operador digitado. O resultado deverá ser exibido em seguida. Utilize o comando escolha. Exemplo: Exemplo: Caso + resultado <- valor1 + valor2 Caso -...

14 Exercícios Elabore um algoritmo que, dada a idade válida de um nadador, classifique-o em uma das seguintes categorias: Elabore um algoritmo que, dada a idade válida de um nadador, classifique-o em uma das seguintes categorias: Não aceito: 0 a 4 anos Não aceito: 0 a 4 anos Infantil: 5 a 10 anos Infantil: 5 a 10 anos Juvenil: 11 a 17 anos Juvenil: 11 a 17 anos Sênior: 17 a 20 anos Sênior: 17 a 20 anos


Carregar ppt "Algoritmos e Programação Thyago Maia Tavares de Farias Aula 6."

Apresentações semelhantes


Anúncios Google