A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Conteúdo: - Matriz. Compreender e manipular matrizes: Objetivos:

Apresentações semelhantes


Apresentação em tema: "Conteúdo: - Matriz. Compreender e manipular matrizes: Objetivos:"— Transcrição da apresentação:

1 Conteúdo: - Matriz

2 Compreender e manipular matrizes: Objetivos:

3 O que é uma matriz? Uma matriz nada mais é do que um vetor com duas ou mais dimensões. Podemos acessar os dados ali contidos através de dois ou mais valores. Esses valores representam as linhas e as colunas. Sintaxe (exemplo de um vetor bidimensional): nome: vetor[, ] de Exemplo: alunos: vetor[1..3,1..3] de caractere

4 O primeiro valor se refere as linhas e o segundo as colunas. O exemplo anterior refere-se a criação de uma matriz com 3 linhas e 3 colunas, conforme imagem abaixo:

5 Como atribuir ou visualizar dados na matriz? Para atribuir dados a uma determinada posição em uma Matriz, manteremos o mesmo padrão para variáveis comuns ou vetores. Para atribuir um determinado valor: alunos[1,2] <- "Kevin Amaral" Atribui a string Kevin Amaral na posição (1,2) da matriz alunos. Para ler determinado valor:... escreva("O nome do aluno é: ",alunos[1,2])... Lê o valor que se encontra na posição (1,2) da matriz alunos.

6 6 Exercício: Fazer um algoritmo para ler e escrever duas matrizes A e B. A matriz A com 2 linhas e 2 colunas e a matriz B com 3 linhas e 2 colunas.

7 7 Escolha - Caso Alternativa para o se - então:... escreva(Digite uma UF:) leia(uf) se uf = MG entao escreva(Estado de Minas Gerais) senaose uf = RJ entao escreva(Estado do Rio de Janeiro) senaose uf = AM entao escreva(Estado do Amazonas) senao escreva(Estado inválido, digite outro.) fimse... escreva(Digite uma UF:) leia(uf) escolha(uf) caso MG escreva(Minas Gerais) caso RJ escreva(Rio de Janeiro) caso AM escreva(Amazonas) outrocaso escreva(Estado inválido) fimescolha


Carregar ppt "Conteúdo: - Matriz. Compreender e manipular matrizes: Objetivos:"

Apresentações semelhantes


Anúncios Google