A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

All rights reserved1 Técnica de Programação II Vetor e Matriz Gireli, Carlos Renato A A mailto: 2/2008.

Apresentações semelhantes


Apresentação em tema: "All rights reserved1 Técnica de Programação II Vetor e Matriz Gireli, Carlos Renato A A mailto: 2/2008."— Transcrição da apresentação:

1 All rights reserved1 Técnica de Programação II Vetor e Matriz Gireli, Carlos Renato A A mailto: 2/2008

2 All rights reserved2 Vetores e Matrizes, são chamados de Array; São variáveis indexadas, isto é, em uma mesma variável podemos armazenar diversos valores; Os valores são identificados pelo nome da variável e por um número ou mais números, dependendo de quantas dimensões tem o vetor ou a matriz. Os números são os índices da matriz, pois indicam a posição do valor (elemento) dentro da Matriz ou do Vetor. Vetores e Matrizes - O Que São?

3 All rights reserved3 Vetor numérico V[1..4] Declaração Inteiro: V[1..4] Vermelho – ÍndicesAzul - Valores Para referenciar o valor 140, temos que indicar V[3], isto é, o valor 140 é o terceiro elemento do Vetor V, ou que o valor 140 encontra-se na terceira posição Exemplo de Vetor

4 All rights reserved4 Matriz numérica M[1..3,1..4] Declaração Inteiro: M[1..3,1..4] Vermelho – ÍndicesAzul - Valores Para referenciar o valor 40, temos que indicar M[1][3], isto é, o valor 40 é o terceiro elemento da Matriz M, ou que o valor 40 encontra-se na terceira primeira linha, terceira coluna. Exemplo de Matriz

5 All rights reserved5 A indicação do índice ou índices é feita sempre entre colchetes [ ], ou em algumas outras linguagens ente parênteses ( ). Como o Vetor é uma matriz que possui dimensão única, temos apenas um índice, que indica a posição que o elemento ocupa dentro do Vetor. Exemplo: V[3]. O número 3 entre os colchetes indica da Posição do Elemento (local onde o valor está armazenado) Comentários

6 All rights reserved6 A Matriz possui mais de uma dimensão, tem uma quantidade de índices igual à quantidade de suas dimensões. No exemplo anterior, a matriz tem duas dimensões, tendo, portanto, dois índices: O primeiro, indicando a linha; O segundo, indicando a coluna; Exemplo: M[2][3], o número 2 indica a linha, e o numero 3 indica a coluna, Posição do Elemento (local do valor armazenado). Comentários

7 All rights reserved7 Para construir algoritmos que manipulam Vetores e Matrizes, utilizamos a estrutura Para – Fim-Para, que é a mais adequada para esse tipo de construção; Algumas linguagens admitem o comando de leitura (Leia) direto para armazenar um valor em um elemento do Vetor ou da Matriz; Outras linguagens só aceitam o armazenamento por atribuição; Usaremos a atribuição porque todas as linguagens suportam; Algoritmos para Manipulação de Vetores

8 All rights reserved8 INICIO INTEIRO: AUX, I, V[1..4]; AUX = 0; PARA I 1 ATÉ 4 FAÇA LEIA(AUX); V[I] = AUX; FIM-PARA; FIM. Algoritmos para Manipulação de Vetores No algoritmo acima, é solicitado a leitura de um número inteiro em AUX que será armazenado em um vetor na posição indicada por I que é a variável que controla o índice do vetor. INICIO INTEIRO:I, V[1..4]; PARA I 1 ATÉ 4 FAÇA LEIA(V[I]); FIM-PARA; FIM. No algoritmo acima, é solicitado a entrada do valor direto no vetor, posição I, que é a variável que controla o índice.

9 All rights reserved9 INICIO INTEIRO: AUX,I,J,M[1..3,1..4]; AUX = 0; PARA I 1 ATÉ 3 FAÇA PARA J 1 ATÉ 4 FAÇA LEIA(AUX); M[I][J] = AUX; FIM-PARA; FIM. Algoritmos para Manipulação de Matrizes No algoritmo acima, é solicitado a leitura de um número inteiro em AUX que será armazenado em uma matriz na posição indicada por I e J que são as variáveis que controlam os índices da matriz, sendo I para a linha e J para coluna. INICIO INTEIRO: I,J,M[1..3,1..4]; PARA I 1 ATÉ 3 FAÇA PARA J 1 ATÉ 4 FAÇA LEIA(M[I][J]); FIM-PARA; FIM. No algoritmo acima, a entrada de um número inteiro será armazenado em uma matriz na posição indicada por I e J que são as variáveis que controlam os índices da matriz, sendo I para a linha e J para coluna.

10 All rights reserved10 Lista de Exercícios 1. Crie um algoritmo que preencha um vetor de 10 posições com os números de 11 a Crie um algoritmo para armazenar em um vetor 5 números reais digitados pelo usuário; 3. Faça um algoritmo que imprima o conteúdo de um vetor de 10 posições; 4. Faça um algoritmo que armazene em um vetor os números pares de 0 a 100 e ao final imprima os números armazenados e a soma dos mesmos. 5. Crie um algoritmos que preencha a seguinte matriz abaixo:


Carregar ppt "All rights reserved1 Técnica de Programação II Vetor e Matriz Gireli, Carlos Renato A A mailto: 2/2008."

Apresentações semelhantes


Anúncios Google