A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Algoritmos Sílder Lamas Vecchi. O Algoritmo é um rascunho do nosso programa.

Apresentações semelhantes


Apresentação em tema: "Algoritmos Sílder Lamas Vecchi. O Algoritmo é um rascunho do nosso programa."— Transcrição da apresentação:

1 Algoritmos Sílder Lamas Vecchi

2 O Algoritmo é um rascunho do nosso programa.

3 1) Faça um algoritmo que receba dois números e exiba o resultado da sua soma.

4 var x, y: inteiro inicio // Seção de Comandos escreval("Digite o primeiro número: ") leia(x) escreval("Digite o segundo número: ") leia(y) escreva("A soma dos números é: ",x+y) fimalgoritmo

5 Exercício: a) Faça um algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos.

6 Exercícios: b)Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecida a distância total percorrida pelo automóvel e o total de combustível gasto.

7 var distancia, combustivel: real inicio // Seção de Comandos escreval("========== Cálculo de consumo médio de combustível =========") escreva("Digite a distância pecorrida: ") leia(distancia) escreva("Digite o combustível gasto: ") leia(combustivel) escreval("O consumo médio de combustível do seu veículo é: ",distancia/combustivel) fimalgoritmo

8 c)A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco) prestações sem juros. Faça um algoritmo que receba um valor de uma compra e mostre o valor das prestações. Parei Aqui

9 var compra, prestacao: real inicio // Seção de Comandos escreval("========== Loja Mamão com Açúcar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <- compra/5 escreval("O cliente deverá pagar 5 prestações de R$",prestacao," cada") fimalgoritmo

10 3) Escrever um algoritmo que leia o nome de um vendedor, o seu salário fixo e o total de vendas efetuadas por ele no mês (em dinheiro). Sabendo que este vendedor ganha 15% de comissão sobre suas vendas efetuadas, informar o seu nome, o salário fixo e salário no final do mês.

11 inicio // Seção de Comandos escreval("<><><><><> Sistema de gestão de vendedores <><><><><>") escreva(">>> Digite o nome do vendedor: ") leia(nome) escreva(">>> Digite o salário: ") leia(salario) escreva(">>> Informe a quantidade de vendas deste no mês: ") leia(vendas) Cálculo da comissão e salário final comissao < * vendas salarioFinal <- salario + comissao limpatela escreval(">>>>>>>>>> RESUMO <<<<<<<<<<") escreval("-- Nome: ",nome) escreval("-- Salário: ",salario) escreval("-- Salário Final (salário + comissão): ",salarioFinal) escreval(">>>>>>>>>><><><><><<<<<<<<<<") fimalgoritmovar nome: caractere salario: real vendas: real comissao: real salarioFinal: real

12 Exercício Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês. Considere fixo o juro da poupança em 0,70% a. m.

13 Função se var numero: inteiro inicio escreva ("Digite um numero: ") leia (numero) se (numero mod 2 = 0) entao escreva (numero," É par") senao escreva (numero," É impar") fimse fimalgoritomo Obs 1: MOD é um operador matemático q retorna o resto da divisão. E ele é um operador de numeros inteiros, ou seja, a variavel numero tem que ser declarada com inteiro. Ex: 10 mod 2 = 0, 5 mod 2 = algoritimo "numero par/impar"

14 Função se C/C++ #include #include int main (void) { int num; printf("digite um numero inteiro: "); scanf("%d",&num); if(num%2==0)//operador % { printf("Par"); } else printf("Ímpar"); } O operador "%" verifica a divisão por um número qualquer é 0. Como na matemática para um número natural, ser par a sua divisão por 2 deve ser 0. #include #include int main (void) { int num; printf("digite um numero inteiro: "); scanf("%d",&num); if(num%2==0)//operador % { printf("Par"); } else printf("Ímpar"); } O operador "%" verifica a divisão por um número qualquer é 0. Como na matemática para um número natural, ser par a sua divisão por 2 deve ser 0.matemática

15 Função se php – Par/Impar if($x % 2 == 0) { echo "par"; } else { echo "impar"; }

16 if(x%2==0) { printf("O número é par"); } else { printf("O numero é impar"); } Função se Java – Par/Impar

17 Função se Faça um algoritmo que mostre a situação de um aluno no colegio em relação a suas notas se esta aprovado, reprovado ou em recuperação. Faça um algoritmo que mostre a situação de um aluno no colegio em relação a suas notas se esta aprovado, reprovado ou em recuperação.

18 Função se Faça um algoritmo identifique se um triângulo é equilátero, isósceles ou escaleno) após o usuário fornecer os três valores.

19 var a,b,c : real inicio // Seção de Comandos escreva("entre com o valor de a: ") leia(a) escreva("entre com o valor de b: ") leia(b) escreva("entre com o valor de c: ") leia(c) se (A=B) e (B=C) entao escreva ("Triangulo Equilátero") senao se (A=B) ou (B=C) ou (A=C) Entao escreva ("Triângulo Isósceles") senao escreva ("Triangulo Escaleno") fimse fimalgoritmo

20 var a,b,c : real inicio // Seção de Comandos escreva("entre com o valor de a: ") leia(a) escreva("entre com o valor de b: ") leia(b) escreva("entre com o valor de c: ") leia(c) se (A

21 Estruturas de repetição //loop com FOR C/C++ 02.#include 02.#include 03.#include 03.#include 04.using namespace std; int main (void){ int x; for (x=1; x<=100; x++) /* inicialização: x começa em 1 critério: executar enquanto x for menor ou igual a 100 incremento (++) será somado 1 a x */ cout << x <<"\t"; cout << x <<"\t"; system ("pause");}

22 #include C/C++ #include #include using namespace std; int main (void){ int par=0; cout <<"Os numeros pares de 0 a 100 sao:\n\n"; while (par<=100){cout <

23 Estrutura de repetição While - JAVA public class ExemploWhile { public class ExemploWhile { public static void main(String args[]) { int contador = 0; while (contador < 50) { System.out.println("Repetição nr: " + contador); contador++;}}}

24 #include do While C/C++ #include #include using namespace std; int main (void){ int nr;do{ cout <<"Digite um numero (0 para finalizar): "; cin >> nr; cin.ignore (); if (nr%2==0) /* se nr for divisivel por 2 (O resto da divisão por 2 for 0)*/ cout <<"Este numero e par\n"; else cout <<"Este numero e impar\n"; system ("pause");system ("cls"); } while (nr!=0); //enquanto nr for diferente de 0 return 0;} Estruturas de repetição

25

26

27

28


Carregar ppt "Algoritmos Sílder Lamas Vecchi. O Algoritmo é um rascunho do nosso programa."

Apresentações semelhantes


Anúncios Google