A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

ALGORITMOS – AULA 3 Operadores Relacionais, Lógicos e comandos de condição.

Apresentações semelhantes


Apresentação em tema: "ALGORITMOS – AULA 3 Operadores Relacionais, Lógicos e comandos de condição."— Transcrição da apresentação:

1 ALGORITMOS – AULA 3 Operadores Relacionais, Lógicos e comandos de condição

2 Expressões Lógicas  Denomina-se expressão lógica aquela cujos operadores são lógicos e/ou relacionais e cujos operandos são relações e/ou variáveis e/ou constantes do tipo lógico. operando lógicooperador lógico constante lógica variável lógica expressão relacional não expressão lógica operando lógico

3 Operadores Relacionais  Os operadores relacionais são utilizados para realizar comparações entre dois valores (constantes, variáveis ou expressões aritméticas) de mesmo tipo primitivo.  O resultado obtido de uma expressão relacional é sempre um valor lógico.

4 Operadores Lógicos  Os operadores lógicos mais utilizados são:

5 Comando de Atribuição  Permite-nos fornecer um valor a uma certa variável, onde o tipo dessa informação deve ser compatível com o tipo da variável.  O comando da atribuição possui a seguinte sintaxe: identificadorexpressão ; expressão aritmética expressão lógica atribuição expressão  Exemplo: lógico: A, B; inteiro: X; A  verdadeiro; X  div 5; B  5 = 3;

6 Comandos de Entrada e Saída  Sintaxe do comando da entrada de dados: entrada de dados leia variável (), ;  Exemplos:  leia (X);  leia (A, XPTO, NOTA);

7 Saída de Dados  Sintaxe do comando da saída de dados: saída de dados escreva variável (), ;  Exemplos:  escreva (Y);  escreva (B, XPTO, MEDIA);  escreva (“Bom Dia ”, NOME);  escreva (“Você pesa ”, X*2, “quilos.”); constante expressão

8 Blocos  Um bloco é definido como um conjunto de ações com uma função definida.  Algoritmo seria um bloco !?  Serve também para definir os limites nos quais as variáveis declaradas em seu interior são conhecidos.  Para delimitar um bloco, utiliza-se os delimitadores: inicio e fim, como segue: blocos inicioaçãofim;,

9 Exemplo de Bloco inicio {início do bloco (algoritmo)} | |{declaração de variáveis} |{seqüência de ações} | fim. {bloco (algoritmo)}

10 Estrutura Sequencial  O Fluxo de Controle segue a mesma sequência linear da nossa escrita, ou seja:  De cima para baixo;  Da esquerda para direita  Cada ação é seguida de um ;  Objetiva separar uma ação da outra  Indica que a próxima ação da sequência deve ser executada

11 Estrutura sequencial início // declaração de variáveis // corpo do algoritmo ação 1; ação 2; ação 3;. ação n; fim. // fim do algoritmo Algoritmo 3.1 – Modelo geral

12 Estrutura sequencial início // declaração de variáveis real: N1, N2, N3, N4, // notas bimestrais MA; // média anual // entrada de dados leia (N1, N2, N3, N4); // processamento MA  (N1 + N2 + N3 + N4) / 4; // saída de dados escreva (MA); fim. Algoritmo Média Aritmética

13 Estruturas de Seleção  São aquelas que permitem alterar o Fluxo de Execução, de forma a selecionar qual parte deve ser executada  Essa “decisão” de execução é tomada a partir de uma condição, que pode resultar apenas em Verdade ou Falsidade  Uma condição é representada por expressões relacionais ou lógicas  As estruturas de seleção podem ser classificadas em simples, compostas ou encadeadas

14 Seleção Simples  Quando a for verdadeira o “bloco verdade” é executado  Quando a for falsa o “bloco verdade” não é executado se então início // início do bloco verdade comando 1; comando 2;... comando n; fim; // fim do bloco verdade fimse;

15 Seleção Simples início // declaração de variáveis real: N1, N2, N3, N4, // notas bimestrais MA; // média anual // entrada de dados leia (N1, N2, N3, N4); // processamento MA  (N1 + N2 + N3 + N4) / 4; // saída de dados escreva (MA); se (MA >= 7) então escreva (“Aluno Aprovado !”); fimse; fim. Algoritmo Média Aritmética com Aprovação

16 Seleção Composta  Quando a for verdadeira o “bloco verdade” é executado  Quando a for falsa o “bloco falsidade” é executado se então início // início do bloco verdade comando 1; comando n; fim; // fim do bloco verdade senão início // início do bloco falsidade comando 1; comando n; fim; // fim do bloco falsidade fimse;

17 Seleção Composta início // declaração de variáveis real: N1, N2, N3, N4, // notas bimestrais MA; // média anual leia (N1, N2, N3, N4); MA  (N1 + N2 + N3 + N4) / 4; escreva (MA); se (MA >= 7) então início escreva (“Aluno Aprovado !”); escreva (“Parabéns !”); fim; senão início escreva (“Aluno Reprovado !”); escreva (“Estude mais !”); fim; fimse; fim. Algoritmo Média Aritmética com aprovação e reprovação

18 Seleção Encadeada  Ocorre quando uma seleção tem como ação uma outra seleção  Uma seleção encadeada pode ser:  Heterogênea: Quando não é possível identificar padrão de comportamento  Homogênea: Quando é possível identificar padrão de comportamento  se – então – se: quando depois de cada então ocorre outro se  se – senão – se: quando depois de cada senão ocorre outro se

19 Seleção Encadeada  Dados três valores A, B, C, verificar se eles podem ser os comprimentos dos lados de um triângulo  Caso positivo, verificar se compõem  Triângulo equilátero  Triângulo isósceles  Triângulo escaleno A B C

20 Seleção Encadeada  Dados três valores A, B, C, verificar se eles podem ser os comprimentos dos lados de um triângulo  Caso positivo, verificar se compõem  Triângulo equilátero – três lados iguais  Triângulo isósceles – dois lados iguais  Triângulo escaleno – todos os lados diferentes A B C

21 Seleção Encadeada  Triângulo: (AB) e (B<>C) e (A<>C) É triângulo?É equilátero?É isósceles?É escaleno?Ações VVFF“Equilátero” VFV-“Isósceles” VFFV“Escaleno” F---“Não é triângulo”

22 Seleção Encadeada Heterogênea início inteiro: A, B, C; // tamanho dos lados leia (A, B, C); se (A

23 Seleção Encadeada Homogênea se – então – se se então se então W; fimse; É equivalente a: se e e e então W; fimse; Cond1Cond2Cond3Cond4Ação VVVVW

24 Seleção Encadeada Homogênea se X=V1 então C1; fimse; se X=V2 então C2; fimse; se X=V3 então C3; fimse; se X=V4 então C4; fimse; X=V1X=V2X=V3X=V4Ação VFFFC1 FVFFC2 FFVFC3 FFFVC4 se X=V1 então C1; senão se X=V2 então C2; senão se X=V3 então C3; senão se X=V4 então C4; fimse; X=V1X=V2X=V3X=V4Ação V---C1 FV--C2 FFV-C3 FFFVC4 se – senão – se

25 Seleção de Múltipla Escolha  Seleções encadeadas homogêneas se-senão-se são bastante frequentes para o tratamento de listas de valor  Para simplificar a escrita, pode-se utilizar o comando escolha.  Adaptando o algoritmo anterior: escolha X caso V1: C1; caso V2: C2; caso V3: C3; caso V4: C4; fimescolha;

26 Seleção de Múltipla Escolha  Construa um algoritmo que, tendo como dados de entrada o preço de um produto e seu código de origem, mostre o preço junto de sua procedência  Caso o código não seja nenhum dos especificados, o produto deve ser encarado como importado  Siga a tabela de códigos abaixo Código de origemProcedência 1Sul 2Norte 3Leste 4Oeste 5 ou 6Nordeste 7, 8 ou 9Sudeste 10 até 20Centro-oeste 25 até 30Nordeste

27 Seleção de Múltipla Escolha início real: Preço; inteiro: Origem; leia (Preço, Origem); escolha Origem caso 1: escreva (Preço, “ – produto do Sul”); caso 2: escreva (Preço, “ – produto do Norte”); caso 3: escreva (Preço, “ – produto do Leste”); caso 4: escreva (Preço, “ – produto do Oeste”); caso 7, 8, 9: escreva (Preço, “ – produto do Sudeste”); caso : escreva (Preço, “ – produto do Centro-Oeste”); caso 5, 6, : escreva (Preço, “ – produto do Nordeste”); caso contrário: escreva (Preço, “ – produto importado”); fimescolha; fim. Algoritmo 3.6 – Múltipla Escolha


Carregar ppt "ALGORITMOS – AULA 3 Operadores Relacionais, Lógicos e comandos de condição."

Apresentações semelhantes


Anúncios Google