A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

Algoritmos e Estruturas de Dados I – Registros Profa. Mercedes Gonzales Márquez.

Apresentações semelhantes


Apresentação em tema: "Algoritmos e Estruturas de Dados I – Registros Profa. Mercedes Gonzales Márquez."— Transcrição da apresentação:

1 Algoritmos e Estruturas de Dados I – Registros Profa. Mercedes Gonzales Márquez

2 Registros Variáveis Compostas Heterogêneas: Variáveis compostas homogêneas consistem de conjuntos de dados do mesmo tipo (inteiros, reais, literais ou lógicos). Quando temos dados de diferentes tipos (heterogêneos) logicamente agrupados não usamos variáveis compostas heterogêneas chamadas registros.

3 Registros Registros são conjuntos de dados logicamente relacionados,mas de tipos diferentes. Exemplo: uma passagem de ônibus formada por um conjunto de dados logicamente relacionados de tipos diferentes, tais como número da passagem (inteiro), origem e destino (literal), data (literal), horário (literal), poltrona (inteiro), distância (real), que são subdivisões do registro (elementos do conjunto), também chamadas de campos.

4 Registros Definição do tipo construído registro: Tipo : registro :... : Fim_Registro Exemplo: Tipo Passagem: registro inteiro:numero literal:origem,destino,data,horario inteiro:poltrona real:distancia Fim_Registro

5 Registros Exemplo: Tipo Ficha_academia: registro inteiro:matricula literal:Nome real:Peso real:Altura literal:Instrutor Fim_Registro

6 Registros Declaração de variável composta do tipo registro definido Tipo-registro : nome_variável Exemplo: Ficha_academia:aluno

7 Registros O registro Ficha_academia agrupa as informações referentes a um aluno da academia. Os registros não podem ser acessados sem especificação individual dos campos. Especifica-se o nome do registro e o nome do campo que se deseja utilizar separado pelo caractere “.” (ponto). Tal ponto estabelece-se separação entre o nome do registro e o nome do campo. Exemplo; Leia (aluno); errado Escreva (aluno); errado Leia (aluno.matrícula); correto Escreva (aluno.nome); correto aluno.peso ← 80.2 correto

8 Registros Algoritmo Tipo Ficha_criança:Registro inteiro:número_vivo literal:nome inteiro:dia inteiro:mês inteiro:ano literal:pai literal:mãe literal:sexo inteiro:ddd inteiro:fone Fim_Registro Ficha_criança:criança Início criança.número_vivo ←1233 criança.nome ← “Andre Schmitt Medina” criança.dia ← 24 criança.mês ← 12 criança.ano ← 2003 criança.pai ← “Aurélio Medina” criança.mãe ← “Cristina Schmitt” criança.sexo ← “M” criança.ddd ← 44 criança.fone ← Fim Vejamos em seguida um algoritmo para armazenar os dados de um recém nascido

9 Registros Os registros vistos até agora possuíam em seus campos apenas informações de tipos primitivos, entretanto, podemos dispor também de campos que são compostos, ou seja, formados por outros tipos construídos. Uma outra forma de armazenar os dados visando facilitar a leitura e interpretação do algoritmo anterior seria:

10 Registros Algoritmo Tipo data : Registro inteiro:dia inteiro:mês inteiro:ano Fim_Registro Tipo telefone : registro inteiro:ddd inteiro:fone Fim-registro Tipo Ficha_criança:Registro inteiro:número_vivo literal:nome data:data_nasc literal:pai literal:mãe literal:sexo telefone: telef Fim_Registro Ficha_criança:criança Início criança.número_vivo ←1233 criança.nome ← “Andre Schmitt Medina” criança.data_nasc.dia ← 24 criança.data_nasc.mês ← 12 criança.data_nasc.ano ← 2003 criança.pai ← “Aurélio Medina” criança.mãe ← “Cristina Schmitt” criança.sexo ← “M” criança.telef.ddd ← 44 criança.telef.fone ← Fim

11 Registros de conjuntos Podemos ter também ter registros com campos vetor ou matriz. Exemplo de Registro com campo de tipo vetor: Registro estoque com as baixas de uma semana Nome: _________________________________ Código: ______________________Preço:_____ Baixa: Tipo Estoque : Registro literal:nome inteiro:código real:preço inteiro:Baixa[6] Fim_Registro Estoque: produto Definição do tipo registro Declaração da variável

12 Registros de conjuntos Exemplo de Registro com campo de tipo matriz : Registro estoque com as baixas de 4 semanas Nome: _________________________________ Código: ______________________Preço:_____ Baixas: Tipo Estoque2: Registro literal:nome inteiro:código real:preço inteiro:Baixa[4][6] Fim_Registro Estoque2: produto2 Definição do tipo registro Declaração da variável

13 Registros de conjuntos Manipulação A manipulação de um registro de conjunto deve obedecer às manipulações próprias de cada estrutura de dados anteriormente definida. Exemplo: a) Para acessar o quanto foi vendido do produto no terceiro dia da quarta semana, teríamos: produto2.baixa[4][3]

14 Registros de conjuntos b) Construir o trecho de algoritmo que, usando a definição de produto2, escreva o nome do produto, o código, o preço e as baixas da segunda semana. … escreva (produto2.nome); escreva (produto2.codigo); escreva (produto2.preço); para j de 1 até 6 repita escreva (produto.Baixa[2][j]); fim para;

15 Registros de conjuntos c) Construa o trecho do algoritmo que totalize por dia da semana todos os dias do mês. … para j de 1 até 6 repita aux ← 0; para i de 1 até 4 repita aux ← aux + produto2.Baixa[i][j] fim para escreva (j, ´totalizou ´, aux, ´ baixas´) fim para

16 Conjunto de Registros Nas estruturas compostas homogêneas (vetores e matrizes) utilizamos somente tipos de dados primitivos. Agora utilizaremos não apenas um tipo primitivo, mas sim os tipos construídos (registros). Exemplo: Suponha que queremos informações relativas à passagens rodoviárias dos 44 lugares de um ônibus. Criamos um vetor no qual cada posição é um elemento de tipo registro (passagem).

17 Conjunto de Registros Tipo Passagem: registro inteiro:numero literal:origem,destino,data,horario inteiro:poltrona real:distancia Fim_Registro Passagem:onibus[44]

18 Conjunto de Registros Ex. Declare um conjunto de registros que comporte as informações de estoque de 500 produtos. Tipo Estoque2: Registro literal:nome inteiro:código real:preço inteiro:Baixa[4][6] Fim_Registro Estoque2: produtos[500]

19 Conjunto de Registros Exemplo: a) Se quisermos saber a baixa do décimo produto, da terceira semana do mês e do quarto dia da semana, escreveríamos: produtos[10].Baixa[3][4]

20 Conjunto de Registros b) Elabore o trecho de um algoritmo que imprima o total de movimentação do estoque para cada um dos 500 produtos:... para N de 1 até 500 repita ACM ← 0; para i de 1 até 4 repita para j de 1 até 6 repita ACM ← ACM + produtos[N].Baixa[i][j] fim para; fim para escreva (produtos[N].nome, ACM); fim para

21 Conjunto de Registros c) Usando o registro de estoque definido nos exemplos, elabore: a) um algoritmo que imprima o produto de maior saída; b) um algoritmo que imprima a diferença percentual entre a maior e a menor saída; c) um relatório com a semana de maior saída de cada produto.

22 Registros (4) Dada a tabela a seguir: Escreva um algoritmo que, dados 500 CODIGOS DE PROFISSÃO (fornecidos em 500 linhas), emita o NOME das profissões correspondentes. A tabela acima também deve ser lida.

23 Registros Algoritmo Tipo profissão : Registro inteiro:codigo literal:nome Fim_Registro profissao:tabela[100] inteiro:i,k,coddessej logico:achou Início para i de 1 até 100 repita leia (tabela[i].codigo)‏ leia (tabela[i].nome)‏ fim para k←1 Repita leia (coddessej)‏ k←k+1 achou←0 para i de 1 até 100 repita se (tabela[i].codigo=coddessej)‏ escreva (tabela[i].nome)‏ achou←1 i←100 fim se fim para se (!achou)‏ escreva(“Código Inválido”)‏ até que (k>500) Fim

24 Registros (5)Faça um algoritmo para criar uma agenda eletrônica. Na agenda poderemos guardar o nome, os s (três, no máximo), o endereço (rua, número, bairro) e os telefones (residencial, comercial, celular) de até 20 pessoas. O algoritmo deve possibilitar ao usuário preencher a agenda e depois consultá-la. Para fazer uma consulta à agenda, o usuário deverá fornecer o nome da pessoa. Se a pessoa estiver cadastrada na agenda, o algoritmo deverá exibir todas as informações sobre ela; caso contrário, o algoritmo deverá informar que a pessoa não está cadastrada.

25 Registros Algoritmo Tipo endereco: Registro literal:rua,bairro inteiro:numero Fim_Registro Tipo agenda : Registro literal:nome, s[3],fones[3] endereco:ende Fim_Registro agenda:pessoas[20] inteiro:i,nomedessej logico:achou Início para i de 1 até 20 repita leia (pessoas[i].nome)‏ leia (pessoas[i].endereco.rua)‏ leia (pessoas[i].endereco.numero)‏ leia (pessoas[i].endereco.bairro)‏ para j de 1 até 3 repita leia (pessoas[i]. s[j]) leia (pessoas[i].fones[j]) fim para leia (nomedessej)‏ enquanto (nomedessej<>“ ”) faça achou←0 para i de 1 até 20 repita se (pessoas[i].nome=nomedessej)‏ escreva (pessoas[i].endereco.rua)‏ achou←1 i←20 fim se fim para se (!achou)‏ escreva(“Nome Inválido”)‏ leia (nomedessej)‏ fim enquanto Fim

26 Registros (6)Faça um algoritmo para criar o cadastro dos funcionários de uma empresa. A empresa possui 50 funcionários. O cadastro deverá conter o nome, o número de matrícula, o grau de escolaridade (1º, 2º ou 3º), o tempo de serviço (em anos) e o salário de cada funcionário. O cadastro de funcionários deverá ser preenchido pelo usuário do algoritmo. Após preenchido o cadastro, o algoritmo deverá percorrê-lo procurando todos os funcionários com 3º grau, que tenham mais de 5 anos de serviço e que ganhem menos de R$ 1000,00 e deverá dar a eles um aumento de 20%. Ao final, o algoritmo deverá exibir o nome e o número de matrícula de todos os funcionários com mais de 10 anos de serviço e que tenham apenas o 1º grau.

27 Registros (7) Faça um algoritmo para criar o cadastro dos produtos comercializados por uma loja. O cadastro deverá conter, para cada produto, o código, sua descrição, o nome do fornecedor, a quantidade mínima permitida em estoque e a quantidade real em estoque. A loja em questão comercializa 100 produtos diferentes. O cadastro de produtos deverá ser preenchido pelo usuário do programa. Após preenchido o cadastro, o programa deverá exibir o código, a descrição e o nome do fornecedor, de todos os produtos cuja quantidade real em estoque é inferior a quantidade mínima permitida.


Carregar ppt "Algoritmos e Estruturas de Dados I – Registros Profa. Mercedes Gonzales Márquez."

Apresentações semelhantes


Anúncios Google