A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

LÓGICA DE PROGRAMAÇÃO Linguagem C Pascal. ESTRUTURAS DE REPETIÇÃO Muito utilizadas na programação. Também são chamadas de laços ou loops. Executam um.

Apresentações semelhantes


Apresentação em tema: "LÓGICA DE PROGRAMAÇÃO Linguagem C Pascal. ESTRUTURAS DE REPETIÇÃO Muito utilizadas na programação. Também são chamadas de laços ou loops. Executam um."— Transcrição da apresentação:

1 LÓGICA DE PROGRAMAÇÃO Linguagem C Pascal

2 ESTRUTURAS DE REPETIÇÃO Muito utilizadas na programação. Também são chamadas de laços ou loops. Executam um determinado bloco de operações repetidamente. Classifica-se de duas formas: Determinadas: definimos a quantidade de vezes que ela irá repetir (for). Indeterminadas: se repetirá enquanto uma condição for atendida (while).

3 EXEMPLOS DE UTILIZAÇÃO Impedir um programa de finalizar até que a opção Sair seja selecionada. Preencher e/ou exibir os itens de uma lista (vetor). Realizar um cálculo contínuo, como fatorial, progressão aritmética e geométrica. Realizar contagens de itens na medida que vão sendo passados. Entre outros exemplos que tenham repetições em seu escopo.

4 ESTRUTURAS DE REPETIÇÃO DETERMINADAS Definimos a quantidade de vezes que ela irá repetir. Eu desenvolvo um programa que imprima o termo Computação Depressão cinco vezes. Uma estrutura de repetição será programada para repetir o comando de impressão na tela cinco vezes. Resultado: Computação Depressão

5 ESTRUTURAS DE REPETIÇÃO DETERMINADAS Exemplo de código: Início Para 1 Até 5 Faça : Escrever(Computação Depressão); Fim_para; Fim_início;

6 ESTRUTURAS DE REPETIÇÃO DETERMINADAS Nas linguagens de programação, as estruturas de repetição determinadas estão sempre atreladas a uma variável. Ou seja, no trecho Para 1 Até 5 Repita:, uma variável (que não foi declarada ainda) esteve em cinco instantes, onde em cada instante seu valor variou de 1 até 5. Modificação incluindo a variável Contador: Início Contador: número inteiro; Para Contador = 1 Até 5 Faça : Escrever(Computação Depressão); Fim_para; Fim_início;

7 ESTRUTURAS DE REPETIÇÃO DETERMINADAS Durante a execução da estrutura de repetição, a variável Contador variou o valor de 1 a 5. Ou seja, ela teve o valor trocado automaticamente pela estrutura de repetição. E se imprimíssemos o valor da variável a cada instante? Início1 Contador: número inteiro;2 Para Contador = 1 Até 5 Faça:3 Escrever(Contador);4 Fim_para;5 Fim_início;

8 ESTRUTURAS DE REPETIÇÃO DETERMINADAS Ou seja, a variável varia seu valor automaticamente a cada instante da estrutura de repetição, mas não deixa de ser uma variável onde podemos manipulá-la e usá-las em outras instruções. Nesse tipo de estrutura, a variável é incrementada de um em um, ou seja, será sempre: valor = valor + 1. Há a possibilidade possível fazermos decrementos, como: valor = valor - 1.

9 ESTRUTURAS DE REPETIÇÃO INDETERMINADAS Se repetirá enquanto uma condição for atendida. São estruturas de repetição aparentemente mais simples, porém são mais complexas e podem levar a programas a um erro chamado loop infinito. Eu desenvolvo um programa que enquanto eu digitar números menores que 10, ele vai imprimir o número. A partir do momento em que eu digitar um número a partir de 10, ele irá interromper a estrutura de repetição.

10 ESTRUTURAS DE REPETIÇÃO INDETERMINADAS Início Valor: número inteiro; Valor = 0; Enquanto(Valor < 10) Faça Escreva(Digite um número menor do que 10:); Leia(Valor); Se(Valor < 10) Então Faça Imprima(Valor); Fim_se; Fim_enquanto; Fim_início;

11 ESTRUTURAS DE REPETIÇÃO INDETERMINADAS Ou seja, não foi predefinido o número de vezes que ele irá se repetir. Ele simplesmente se repetirá até que a condição da estrutura de repetição deixe de ser atendida. O programa será executado por toda a eternidade até que seja inserido um número a partir de 10. Isso não caracteriza um loop infinito, pois a todo momento há a entrada do usuário com o valor e esse valor pode provocar a saída da estrutura de repetição. O loop infinito é caracterizado pela ausência de uma possibilidade de provocação de saída da estrutura de repetição.

12 ESTRUTURAS DE REPETIÇÃO INDETERMINADAS Início Valor: número inteiro; Valor = 1; Enquanto(Valor = 1) Faça Escreva(Estou num loop infinito!); Fim_enquanto; Fim_início; Desta forma, o valor da variável Valor não variará durante a execução da estrutura de repetição, causando um loop infinito.

13 VERIFICAÇÃO DA CONDIÇÃO NAS ESTRUTURAS DE REPETIÇÃO INDETERMINADAS Há dois momentos que podemos definir para realizar a verificação da condição numa estrutura condicional indeterminada. Pode ser feita antes de executar o bloco de operações, assim como pode ser feita depois da execução do bloco de operações. InícioInício Enquanto([condição]) FaçaFaça //...//... Fim_enquanto;Enquanto([condição); Fim_inícioFim_início

14 VERIFICAÇÃO DA CONDIÇÃO NAS ESTRUTURAS DE REPETIÇÃO INDETERMINADAS Na linguagem C funciona da forma que foi mostrado no exemplo anterior. Na linguagem Pascal é diferente. Em vez de faça- enquanto (do-while), fazemos o inverso. Ele irá repetir o bloco de instrução até que uma condição seja verdadeira, como um repita- até que (repeat-until). InícioInício Enquanto([condição]) FaçaRepita //...//... Fim_enquanto;Até Que([condição); Fim_inícioFim_início

15 VERIFICAÇÃO DA CONDIÇÃO NAS ESTRUTURAS DE REPETIÇÃO INDETERMINADAS As condições, assim como nas estruturas condicionais, são verificas logicamente, ou seja, deve haver os valores, operadores lógicos e, caso necessário, operadores relacionais, para quando houver mais de uma condição. Exemplo: Início Enquanto((valor1 > 34) e (valor2 < 75)) Faça //... Fim_enquanto; Fim_início

16 RESUMO DAS ESTRUTURAS DE REPETIÇÃO Determinada: Variávei + 1; Chegou ao fim? Indeterminada: Condição ainda é verdadeira? Indeterminada com loop infinito: Condição nunca será falsa


Carregar ppt "LÓGICA DE PROGRAMAÇÃO Linguagem C Pascal. ESTRUTURAS DE REPETIÇÃO Muito utilizadas na programação. Também são chamadas de laços ou loops. Executam um."

Apresentações semelhantes


Anúncios Google