A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

CEPMAT Curso Técnico em Informática Linguagem de Programação Prof.º Cleycom Maichel.

Apresentações semelhantes


Apresentação em tema: "CEPMAT Curso Técnico em Informática Linguagem de Programação Prof.º Cleycom Maichel."— Transcrição da apresentação:

1 CEPMAT Curso Técnico em Informática Linguagem de Programação Prof.º Cleycom Maichel

2 Objetivo da Aula de Hoje Especificar um método que traduza uma sequência lógica que leve a construção de algoritmos em português estruturado. Competência -Codificar algoritmos em português estruturado Base Tecnológica -Etapas para estruturar e resolver um problema -Pseudocódigo

3 Problemas & Algoritmos Para resolver um problema através de um computador é necessário encontrar em primeiro lugar uma maneira de descrevê-lo de uma forma clara e precisa.

4 Problemas & Algoritmos É também preciso que encontremos uma sequência de passos que conduzam à sua resolução. Esta sequência de passos é designada por algoritmo.

5 Problemas & Algoritmos A noção de algoritmo é central para toda a informática.

6 Construindo os Primeiros Algoritmos De forma genérica, a construção de um algoritmo se resume às seguintes etapas: a)Entendimento do problema; b)Elaboração da solução algorítmica; e c)Codificação da solução no Português estruturado;

7 Entendimento do Problema Enunciado: Faça um algoritmo que leia o valor do raio e calcule a área do círculo correspondente.

8 Entendimento do Problema Dos tempos de escola lembramos que o cálculo da área de um círculo é dado pela fórmula Pi*Raio². Da fórmula podemos extrair que os dados dependentes são: A constante Pi que vale aproximadamente 3, O valor da medida do Raio Portanto...

9 Elaboração da Solução Algorítmica ENTRADA Processamento SAÍDA É importante perceber que, na criação de um algoritmo, o problema sempre será dividido em três fases:

10 Elaboração da Solução Algorítmica Concluimos que o argumento de entrada necessário é o valor do raio, que será lido e colocado na variável que podemos chamar de Raio. Obs: A constante Pi normalmente é existente em todas as linguagem de programação e vamos considerar sua existência no português estruturado também.

11 Elaboração da Solução Algorítmica O processamento aqui é o cálculo da área que é dada pela fórmula Pí*Raio² que podemos armazenar em uma variável que chamaremos de Area.

12 Elaboração da Solução Algorítmica Basta exibir o conteúdo da variável Area

13 Formas da representação de Algoritmos comando 1 comando 2 comando n... FluxogramaLinguagem Algorítmica comando 1 comando 2 … comando n

14 Representações de um algoritmo Diagrama de Nassi-Shneiderman ou Chapin Ler a medida do raio do círculo (Raio) Area Pi * Raio * Raio Exibir a Área

15 Representações de um algoritmo Fluxograma ou Diagrama de Blocos Raio Inicio Area Pi * Raio * Raio Area fim

16 Codificação da Solução no Português Estruturado (P.E.) Algoritmo Var Inicio FimAlgoritmo

17 Codificação da Solução em P.E. Algoritmo Cálculo da área do Círculo Var Raio, Area : real Inicio Escreva( Entre com o valor do raio: ) Leia( Raio ) Area Pi * Raio * Raio Escreva( A área do círculo com raio, Raio, é, Area ) FimAlgoritmo

18 Entendimento do Problema Enunciado: (2º Exemplo) Faça um algoritmo que calcule a média aritmética entre duas notas quaisquer de um aluno fornecidas pelo usuário e informe a sua situação quanto à aprovação, neste caso, obtida atingindo-se média superior ou igual a sete.

19 Argumentos de Entrada: Duas notas quaisquer (Ex: Nota1 e Nota2) Processamento: Média Aritmética, Media (Nota1+Nota2)/2. Verificar se a média é maior que 7 Argumentos de Saída: Exibir o conteúdo da variável Media. Situação: Aprovado ou Reprovado. Elaboração da Solução Algorítmica

20 Diagrama de Nassi-Shneiderman ou Chapin Leia (Nota1, Nota2) Início Média (Nota1+Nota2)/2 SimNão Média >= 6 Escreva Reprovado Escreva Aprovado Fim Figura 2.3 Diagrama de Chapin para o algoritmo do cálculo da média de um aluno

21 Fim Fluxograma ou Diagrama de Blocos Inicio Media (Nota1+Nota2)/2 Media Ler Nota1 Ler Nota2 Media>=7 Aprovado Reprovado Não Sim

22 Algoritmo Média Aritmética entre dois valores Var nota1, nota2, media : real Início Leia (nota1, nota2) media (nota1+nota2)/2 Escreva (Media=,media) Se (media >= 7) Entao Escreva ( Aprovado!) Senao Escreva ( Reprovado!) FimSe FimAlgoritmo Codificação da Solução em P.E.

23 Sobre o aprendizado de Algoritmos O aprendizado de algoritmos não se consegue a não ser através de muitos exercícios. Algoritmos não se aprende: - Copiando Algoritmos - Estudando Algoritmos Algoritmos só se aprendem: - Construindo Algoritmos - Testando Algoritmos

24 Bibliografia GUIMARÃES, A.M., Algoritmos e estruturas de dados, Rio de Janeiro, LTC, FORBELLONE, André L.V.; Henri Frederico E., Lógica de programação: a construção de algoritmos e estruturas de dados, São Paulo, Pearson Prentice Hall, Ano 2005, 3ª Edição. PINTO, Sandra Rita, Treinamento em Lógica de Programação, São Paulo, Digerati Books, 2009.

25 Tema: Construindo os Primeiros Algoritmos Disciplina: Linguagem de Programação Prof.º Cleycom Maichel


Carregar ppt "CEPMAT Curso Técnico em Informática Linguagem de Programação Prof.º Cleycom Maichel."

Apresentações semelhantes


Anúncios Google