A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

A LGORITMO “Tudo se torna fácil quando pelo prazer é compreendido.”

Apresentações semelhantes


Apresentação em tema: "A LGORITMO “Tudo se torna fácil quando pelo prazer é compreendido.”"— Transcrição da apresentação:

1 A LGORITMO “Tudo se torna fácil quando pelo prazer é compreendido.”

2 Enquanto... Faca Sintaxe: Enquanto condição faca comando1; comando2; FimEnquanto; Estrutura de Repetição

3 Enquanto... Faca Exemplo: Faça um programa que leia 4 números. Imprima apenas os pares. c:=1 Enquanto c<5 faca escreva(“Digite o número: ”) leia(num) Se num mod 2=0 entao escreva(num, “é par.”) FimSe c:=c+1 FimEnquanto Estrutura de Repetição

4 Desenvolva um programa em Pascal que informe o valor do auxilio maternidade de uma funcionária. Lembrando que o calculo é feito através da media dos seis últimos salários. Resolução: Algoritmo maternidade; Var sal, soma, med: real c: inteiro Inicio c:=1 Enquanto c<=6 faca Inicio escreva(“Digite o salário:”) leia(sal) soma:=soma+sal med:=soma/6 c:=c+1 FimEnquanto Escreva(“O valor do auxilio é de: “, med:2:2) Fim. Exercício Resolvido

5 Estrutura de Repetição Para... faca Sintaxe: Para limite faca comando1 comando2 FimPara

6 Para... faça Ex.: Faça um algoritmo que leia 5 números. Para i de 1 ate 5 faca Escreva(“Digite o número: ”) leia(n) FimPara Estrutura de Repetição

7 Exercício de Resolvido Vamos resolver o algoritmo da maternidade dessa vez com a estrutura de repetição Para. Resolução: Algoritmo maternidade; Var sal, soma, med: real i: inteiro Inicio Para i de 1 até 6 faca escreva(“Digite o salário:”) leia(sal) soma:=soma+sal med:=soma/6 FimPara Escreva(“O valor do auxilio é de:”, med:2:2) FimAlgoritmo

8 Exercícios de Fixação Elabore um algoritmo que calcule e imprima o salário de 50 professores, onde o usuário deverá entrar com o nível em que leciona, número de aulas dadas e o percentual de desconto do INSS. Para os professores do nível fundamental o valor da hora aula é de R$ 14,50; para os professores do nível médio o valor da hora aula é de R$ 17,30; e para os professores do nível superior é de R$ 42, 80.

9 Algoritmo prof; Var i: inteiro nivel: caracter qntaulas, inss, salb,sall:real Início Para i de 1 ate 50 faca Escreva(“Digite o Nível em que leciona:”) leia(nivel) Escreva(“Digite a quantidade de tempos:”) leia(qntaulas) Escreva(“Digite a porcentagem do desconto do INSS:”) leia(inss) Se nivel = “Fundamental” entao salb:= quantaula * 14.5 * 4.5 Senao Se nivel = “Medio” entao salb:= quantaula * 17.3 * 4.5

10 Senao Se nivel = “Superior” entao salb:= quantaula * 14.5 * 4.5 Senao Escreva(“Nível não cadastrado!”) Fimse sall:= salb – (salb * inss) Escreva(“O Salário Líquido é de: ”, sall) FimPara FimAlgoritmo


Carregar ppt "A LGORITMO “Tudo se torna fácil quando pelo prazer é compreendido.”"

Apresentações semelhantes


Anúncios Google