A apresentação está carregando. Por favor, espere

A apresentação está carregando. Por favor, espere

LINGUAGEM LOGO Prof. Claudio de Oliveira. O que é o LOGO? É uma linguagem de programação interpretada. É utilizada com grande sucesso como ferramenta.

Apresentações semelhantes


Apresentação em tema: "LINGUAGEM LOGO Prof. Claudio de Oliveira. O que é o LOGO? É uma linguagem de programação interpretada. É utilizada com grande sucesso como ferramenta."— Transcrição da apresentação:

1 LINGUAGEM LOGO Prof. Claudio de Oliveira

2 O que é o LOGO? É uma linguagem de programação interpretada. É utilizada com grande sucesso como ferramenta de apoio ao ensino regular e por aprendizes em programação de computadores. Ela implementa, em certos aspectos, a filosofia construtivista, segundo a interpretação de Seymour Papert, co-criador da linguagem junto com Wally Feurzeig.

3 LOGO... Desenvolvida por Seymour Papert, um educador matemático, nos anos sessenta, no MIT - Massachusetts Institute of Technology, de Cambridge, MA, Estados Unidos, e adaptada para o português em 1982, na Unicamp, pelo Núcleo de Informática Aplicada à Educação (NIED), a linguagem logo vem sendo utilizada para trabalhar com crianças e adolescentes.

4 Ambiente LOGO...

5 Aplicação... Ensino de matemática Geometria Robótica Outras áreas do conhecimento...

6 Comandos básicos ComandoValorAção pfpixelMovimenta para frente ptpixelMovimenta para tráz pegrausGira para esquerda pdgrausGira para direita repitanumeroRepetir comandos

7 Exemplos Quadrado passo-a-passo – pf 100 – pd 90 – pf 100 – pd 90 – pf 100 – pd 90 – pf 100 Triângulo passo-a-passo – pf pd pf pd pf 100 Circulo – pf 1 pd 1 Comando repita – repita 4 [pf 100 pd 90]

8 Criando procedimentos Aprenda petala – Repita 90 [pf 1 pd 1] – Pd 90 – Repita 90 [pf 1 pd 1] – Fim Aprenda flor – repita 7 [petala pd 40] – fim

9 Kit para robótica... Do cabo ao bluetooth


Carregar ppt "LINGUAGEM LOGO Prof. Claudio de Oliveira. O que é o LOGO? É uma linguagem de programação interpretada. É utilizada com grande sucesso como ferramenta."

Apresentações semelhantes


Anúncios Google